mohammad

ارورappcompat_v7در ساخت پروژه اندروید

mohammad ۱۳۹۴/۱۲/۲۲ 33 برنامه‌نویسی اندروید

با سلام خدمت دوستان عزیز من تازه برنامه نویسی اندرویدو شروع کردم جدیدا ی مشکل تو اکلیپس برام پیش اومده که وقتی میخوام پروژه جدیدی بسازم و minimumSDKرو روی 2.2 میزارم همراه با پروژه ی فایل به اسم appcompat_v7میاد.که ارور داره ولی اگه mimimumSDKرو ببرم بالای 4 این مشکلو ندارم.خیلی تو نت گشتم راه های زیادم امتحان کردم از دستی وارد کردن appcompat_v7 به مسیر نصب sdk تا اپ دیدت sdkولی هیچ کدوم موثر نبود.خواهشن هر کی بلده کمک کنه این ارور خیلی رو مخه.

پاسخ‌ها به این تاپیک
stack programer
stack programer
۱۳۹۴/۱۲/۲۲

سلام،مشکلی که برای شما پیش میاد،مربوط به dependency است،که برای ورژن پایین تر لول اندروید به این بخش وابسته است،که نمی تونه یک سری پس را تشخیص بده.


To resolve this issue, Right Click on appcompat_v7 library and select Properties Click on Android Option, Set Project Build Path as Android 5.0 (API level 21) Apply Changes. Go to project.properties file under appcompat_v7 library, Set the project target as : target=android-21 Clean + Build appcompat_v7 library and your projects


برای اطلاعات بیشتر http://code2care.org/pages/appcompat_v7-errors-after-updates-to-api-level-21-material-theme/ فلسه ساخت همچین زیر پروژه در پروژه شما این است،که وقتی مینیمم اس دی کی خودت مثلا را api10 است،اما تارگت اپت api15 است،داخل اپت یک سری چیز ها برای api 15 است،برای اینکه این ها داخل مینیم ای پی ای یعنی api 10 کار کند این زیر پروژه یا اصلا لایبرری به پروژه ات اضافه می شود.