netwons

نمایش ارور هنگام نصب پکیج در لاراول۵.۷

netwons ۱۳۹۸/۰۸/۰۸ مباحث عمومی برنامه‌نویسی

با سلام
composer require roumen/sitemap
این پکیج نصب نمیشه و ارور زیر رو نمایش میده

Installation failed, reverting ./composer.json to its original content.
سیستم لاراول من ۵.۷هست اما در سایت ها نسخه پکیج برای۵.۶هست امکان داره از این باشه
الان این نسخه رو من در سایتhttps://packagist.org/packages/laravelium/sitemap?query=sitemap چک کردم میگه که این پکیج رها شده پس میشه یک پکیج دیگه راهنمایی کنید و آموزشش رو هم قرار بدید

بعضی افراد به من میگن این کار رو انجام بدم ایا درسته یا نه

اگه پوشه vendorرو پاک کنم و composer updateبزنم امکان داره مشکل حل بشه

پاسخ‌ها به این تاپیک
سامان زاهدی
سامان زاهدیتوسعه‌دهنده سمت سرور با زبان php
۱۳۹۸/۰۸/۰۹

سلام

در صفحه‌ی پکیج roumen/sitemap گفته شده که از پکیج laravelium/sitemap استفاده کنید

فقط کافیه توی ترمینال در پوشه‌ی اصلی پروژه‌تون دستور زیر رو وارد کنید:

composer require laravelium/sitemap

بعد از تکمیل نصب دستورات زیر رو هم وارد کنید ممکنه مفید باشه:

composer clear
composer dump-autoload
php artisan optimize:clear
netwons
netwons
۱۳۹۸/۰۸/۰۹

موقع نصب این ارور رو میده

Installation failed, reverting ./composer.json to its original content.

در پاسخ به

سامان زاهدی
سامان زاهدیتوسعه‌دهنده سمت سرور با زبان php
۱۳۹۸/۰۸/۰۹

متن کامل خطا رو بفرستید.

در پاسخ به

netwons
netwons
۱۳۹۸/۰۸/۰۹
Your requirements could not be resolved to an installable set of packages.

 Problem 1
 - The requested package elasticsearch/elasticsearch (locked at v6.7.2, required as ~7.0) is satisfiable by elasticsearch/elasticsearch[v6.7.2] but these conflict with your requirements or minimum-stability.
 Problem 2
 - Conclusion: don't install elasticsearch/elasticsearch v7.3.0
 - Conclusion: don't install elasticsearch/elasticsearch v7.2.2
 - Conclusion: don't install elasticsearch/elasticsearch v7.2.1
 - Conclusion: don't install elasticsearch/elasticsearch v7.2.0
 - Conclusion: don't install elasticsearch/elasticsearch v7.1.1
 - Conclusion: don't install elasticsearch/elasticsearch v7.1.0
 - Conclusion: don't install elasticsearch/elasticsearch v7.0.2
 - Conclusion: don't install elasticsearch/elasticsearch v7.0.1
 - Conclusion: don't install elasticsearch/elasticsearch v7.0.0
 - Conclusion: don't install elasticsearch/elasticsearch 7.2.x-dev
 - ruflin/elastica 6.1.1 requires elasticsearch/elasticsearch ^6.0 -> satisfiable by elasticsearch/elasticsearch[6.0.x-dev, 6.5.x-dev, 6.7.x-dev].
 - ruflin/elastica 6.1.1 requires elasticsearch/elasticsearch ^6.0 -> satisfiable by elasticsearch/elasticsearch[6.0.x-dev, 6.5.x-dev, 6.7.x-dev].
 - ruflin/elastica 6.1.1 requires elasticsearch/elasticsearch ^6.0 -> satisfiable by elasticsearch/elasticsearch[6.0.x-dev, 6.5.x-dev, 6.7.x-dev].
 - Can only install one of: elasticsearch/elasticsearch[7.0.x-dev, 6.0.x-dev].
 - Can only install one of: elasticsearch/elasticsearch[7.0.x-dev, 6.5.x-dev].
 - Can only install one of: elasticsearch/elasticsearch[7.0.x-dev, 6.7.x-dev].
 - Installation request for elasticsearch/elasticsearch ~7.0 -> satisfiable by elasticsearch/elasticsearch[7.0.x-dev, 7.2.x-dev, v7.0.0, v7.0.1, v7.0.2, v7.1.0, v7.1.1, v7.2.0, v7.2.1, v7.2.2, v7.3.0].
 - Installation request for ruflin/elastica (locked at 6.1.1, required as ^6.1) -> satisfiable by ruflin/elastica[6.1.1].


Installation failed, reverting ./composer.json to its original content.

الان این پکیج ها مشکل سازن اما وقتی میخوام پاک کنم هم پاک نمیشن

در پاسخ به

سامان زاهدی
سامان زاهدیتوسعه‌دهنده سمت سرور با زبان php
۱۳۹۸/۰۸/۱۱

این خطا اصلا به پکیجی که میخواید نصب کنید مربوط نیست.

توی فایل composer.json در قسمت require پکیج‌هایی که خطا دارن رو حذف کنید و بعد دستور composer install رو بزنید.

در پاسخ به