jalilzadeh.asg

مشکل در تعریف Virtual Host راهنمایی برای رفع خطای NET::ERR_CERT_AUTHORITY_INVALID

jalilzadeh.asg ۱۳۹۸/۰۲/۲۲ زبان برنامه‌نویسی پی‌اچ‌پی

سلام من تحت ویندوز با زمپ ورژن 3.2.3 (نهایی) دارم کار میکنم و با مرورگر کروم آخرین ورژن در حال تست کردن کد ها هستم در بخش ساختن سرور مجازی این کد ها رو داخل فایل httpd.conf سرور آپاچی وارد کردم

<VirtualHost 127.0.0.1:80>
	ServerName mvc.dev
	DocumentRoot "C:\xampp\htdocs\mvc\public"
</VirtualHost>
<Directory "C:\xampp\htdocs\mvc\public">
	Options Indexes FollowSymLinks
	AllowOverride All
	Order Allow,Deny
	Allow From All
</Directory>

و در فایل hosts مقدار زیر رو هم اضافه کردم

127.0.0.1 mvc.dev

ولی زمانی که تو مرورگر مقدار mvc.dev رو وارد میکنم چنین اروری به نمایش درمیاد:

Your connection is not private

Attackers might be trying to steal your information from mvc.dev (for example, passwords, messages, or credit cards). Learn more

NET::ERR_CERT_AUTHORITY_INVALID

و وقتی بر روی

NET::ERR_CERT_AUTHORITY_INVALID

کلیک میکنم اطلاعات زیر به نمایش در میاد

Your connection is not private

Attackers might be trying to steal your information from mvc.dev (for example, passwords, messages, or credit cards). Learn more

NET::ERR_CERT_AUTHORITY_INVALID

Subject: localhost

Issuer: localhost

Expires on: Nov 9, 2019

Current date: May 12, 2019

PEM encoded chain:
-----BEGIN CERTIFICATE-----
MIIBnzCCAQgCCQC1x1LJh4G1AzANBgkqhkiG9w0BAQUFADAUMRIwEAYDVQQDEwls
b2NhbGhvc3QwHhcNMDkxMTEwMjM0ODQ3WhcNMTkxMTA4MjM0ODQ3WjAUMRIwEAYD
VQQDEwlsb2NhbGhvc3QwgZ8wDQYJKoZIhvcNAQEBBQADgY0AMIGJAoGBAMEl0yfj
7K0Ng2pt51+adRAj4pCdoGOVjx1BmljVnGOMW3OGkHnMw9ajibh1vB6UfHxu463o
J1wLxgxq+Q8y/rPEehAjBCspKNSq+bMvZhD4p8HNYMRrKFfjZzv3ns1IItw46kgT
gDpAl1cMRzVGPXFimu5TnWMOZ3ooyaQ0/xntAgMBAAEwDQYJKoZIhvcNAQEFBQAD
gYEAavHzSWz5umhfb/MnBMa5DL2VNzS+9whmmpsDGEG+uR0kM1W2GQIdVHHJTyFd
aHXzgVJBQcWTwhp84nvHSiQTDBSaT6cQNQpvag/TaED/SEQpm0VqDFwpfFYuufBL
vVNbLkKxbK2XwUvu0RxoLdBMC/89HqrZ0ppiONuQ+X2MtxE=
-----END CERTIFICATE-----

 

لطفا راهنمایی کنید که چه‌ طور این مشکل رو رفع کنم

پاسخ‌ها به این تاپیک
گیم اور
گیم اور
۱۳۹۸/۰۳/۰۳

mvc.dev رو ssl باز میکنی ؟

اگه آره که تنظیمات آپاچی رو هم باید تغییر بدی، باید یه Virtual Host برای ssl هم بسازی

چون Virtual Host برای ssl نساختی، درخواست داره میره برای هاست پیشفرض ssl آپاچی

<VirtualHost 127.0.0.1:443>
	ServerName mvc.dev
	DocumentRoot "C:\xampp\htdocs\mvc\public"
</VirtualHost>
<Directory "C:\xampp\htdocs\mvc\public">
	Options Indexes FollowSymLinks
	AllowOverride All
	Order Allow,Deny
	Allow From All
</Directory>
</VirtualHost>
امیرحسین مشفقی
امیرحسین مشفقییک عدد برنامه نویس
۱۳۹۸/۰۲/۲۲

به لینک زیر برید و و اون قسمت که زرد نشون داده یا نوشته Allow invalid certificates for resources loaded from localhost. رو enable کنید

chrome://flags/#allow-insecure-localhost

jalilzadeh.asg
jalilzadeh.asg
۱۳۹۸/۰۲/۲۴

سلام

این کار رو هم انجام دادم ولی باز همون پیغام خطا رو دارم

در پاسخ به