sms50010

ارور مربوط به بیلد شدن: AAPT2 error

sms50010 ۱۳۹۸/۰۱/۰۱ برنامه‌نویسی اندروید

سلام دوستان.

من در اجرا برنامه روی ایمولاتور خودم (تست شده با چند دیوایس) به ارور AAPT2 error: check logs for details مواجه میشم.

در یوتیوب فیلمی رو دیدم برای رفع این مشکل ولی نتونست کمکم کنه. جزییات لاگ کت:

1-E: Could not find class 'android.graphics.drawable.RippleDrawable', referenced from method android.support.v7.widget.AppCompatImageHelper.hasOverlappingRendering

2-E: tid 4459: eglSurfaceAttrib(1199): error 0x3009 (EGL_BAD_MATCH)

مرسی

پاسخ‌ها به این تاپیک
مهدی ویژه
مهدی ویژهتوسعه دهنده اندروید
۱۳۹۸/۰۱/۰۶

مشکل این ارور پیدا نشدن لایبراری مذکور در گوشی مورد تست هستش که احتمالا در حال اجرا سیستم عامل اندروید 4.4 است. این مشکل احتمالا با جایگزین کردن DrawableCompat حل بشه و یا اینکه چک ورژن اندروید رو به کدتون اضافه کنید که در این صورت از قابلیت ripple در اندروید های زیر 5 محروم خواهید بود.

if (Build.VERSION.SDK_INT >= Build.VERSION_CODES.LOLLIPOP)
 {
 view.setBackgroundDrawable(getResources().getDrawable(R.drawable.));

 }

و یا همچنین می‌توانید از لایبراری زیر استفاده کنید که اندروید های زیر ورژن 5 هم ساپورت می‌کند.

RippleEffect